The radio syncing works pretty well, and can function several blocks away in ideal conditions, but it can be affected by other objects and RF emitters around it and does not always work perfectly. 


However if one of your clubs seems to be losing its grouping, doesn't control or respond as reliably as the others, please mark it to see if it's consistently that club.


First confirm that your clubs are grouped correctly: 

  • Both units should display the same color in grouping mode (P5m1) - but just because they are the same color doesn't mean they are in the same group. 
  • To group, you must enter adjust and select the color while both units are in P5m1 even if they are already the same color. It helps to enter adjust and select the group color one at a time.
  • Did you save the grouping? To save - hold past off until the light turns back on again.
  • Did a light connect to another group somewhere in your building?


  1. Try saving “no group” (blinking red group) and leaving your prop off for more than 1 minute. And then regrouping.
  2. Try grouping a few times - it doesn’t always work the first time.
  3. Try a reset - see pic below - this often fixes it. Not typical, but you may need to reset it a few times, then group again.
  4. You can also try power-cycling the radio in one of 2 ways: 
  • let the battery drain completely until the club turns off, then charge it, OR 
  • change the grouping to the blinking red group and save it, then turn the club off for 2 minutes before turning it back on again.

    If this troubleshooting doesn’t work or if you’d like more help, email as and we’ll take care of you.