Most people are updating their new firmware with no issues, but as with all technology, things don’t always work perfectly.


Most issues have been with Windows. If you are encountering problems, here are some troubleshooting tips below that might help. 


If the tips below don’t help, please email us at support@flowtoys.com with screenshots of what is happening, what machine and operating system you’re running. We will fix bugs as quickly as we can.


Troubleshooting: 

  1. Select your prop type and firmware and go to "next step" BEFORE connecting your capsule/club!
  2. Leave your capsule/club off and disconnected from any cable for 1 full minute before connecting. (No need to wait longer, just 61 seconds will do.)
  3. If it's still not connecting, try a "soft reset" on your capsule/club (click here for soft reset instructions for capsules or for clubs).
  4. If it's still not working, please restart your computer.
  5. Also make sure you are using a good USB cable. Many usb cables only do power, no data. The cables we include do power and data, unless they are breaking/wearing out or defective.
  6. Make sure there is no debris/damage in your USB jack that might prevent good data connection.


We’ve had a few people fix the issue by simply re-starting their computer, or switching their USB cable.


One user reported: "I realized that my computer wasn't recognizing it properly via USB, so I ejected it rather than just pulling the cable out. Disconnected it, turned it off, gave it a minute, reconnected. And that did the trick!”


Another user said: "When you're on the connect screen with the usb cable plugged in, you only have a few seconds to connect to capsule to the pc before the upload button greys out (goes back to being un-clickable)."